9991F83E5BA0725F27


Linux Mint Debian Edition, 즉 LMDE 3 Cindy가 2018년 8월 31일에 출시되었습니다.

데비안 9 Stretch에 기반하며, 커널은 4.9.110-3+deb9u4 버전을 탑재하고 있습니다.

특히, 이 커널은 데비안 9 Stretch에서도 지난 8월 22일에 발표된 가장 최신의 커널이죠.


 * LMDE 3 Cindy 정식 버전의 출시가 승인됨! : http://la-nube.tistory.com/469


 * LMDE 3 Cindy 출시와 LMDE 2 Betsy 지원종료 소식 : http://la-nube.tistory.com/470


--


스왑


설치 과정에서 우분투 18.04 LTS 및 리눅스민트 19와 달리 스왑 파티션을 요구합니다.

물론, 스왑 파티션을 아예 할당하지 않거나, 스왑 파티션 없이 스왑 파일(/swapfile)로 만들어도 됩니다.


--


입력기


다음은 가장 중요하다고 할 수 있는 한글 입력기 부분입니다.

제가 주로 사용하는 uim, 그리고 최근에 써보고 있는 fcitx만 살펴보겠습니다.


먼저, uim 입력기에서는 우분투 18.04 LTS 및 리눅스민트 19와 달리 큰 변화가 없었습니다.

여전히 uim 패키지와 함께 uim-byeoru라고 하는 벼루 패키지가 필요합니다.

우분투 18.04 LTS 및 리눅스민트 19부터는 uim에 uim-byeoru가 통합되었지만, LMDE 3 Cindy는 아직입니다.


$ sudo apt-get install uim uim-byeoru


한편, fcitx는 관련 패키지를 전부 깔아서 시도해보았는데, 한국어 입력이 되지 않아서 결국 포기했습니다.

아직 제가 fcitx 패키지에 익숙하지 않아서 그런 것 같습니다. ㅜㅜ

LMDE 3 Cindy에서 fcitx를 설치하셔서 한국어 입력에 성공하신 분 있으시면 좀 알려주세요.


99377D335BA0729E1A


--


Firefox


LMDE 3 Cindy에서는 리눅스민트 19와 달리 Firefox를 ESR(Extended Support Release)로 제공합니다.

그래서 2018년 9월 18일 기준으로, 최신 버전인 62.0이 아닌, ESR의 최신 버전인 60.2.0이 설치됩니다.


Firefox ESR은 일반 버전의 Firefox에 비하여 매우 천천히 버전 업이 이루어집니다.

주로 기존의 데비안 계열에서 쓰던 Firefox였는데, LMDE 3 Cindy로 올라오면서 LMDE에서도 쓰이게 되었습니다.

참고로 LMDE 2 Betsy 시절에는 리눅스민트에서 따로 만든 일반 버전의 Firefox를 써왔습니다.


다만, 패키지의 이름은 여전히 Firefox입니다.

다음에서 알 수 있듯이 리눅스민트에서 따로 만들었기 때문이죠.

betsy를 cindy로 변경하지 않고, 그냥 계속 사용하네요 ㅎㅎ;; (개발자의 귀차니즘?)

이름이야 어느 순간 cindy로 바뀔 것이라서 아무런 상관이 없습니다.


firefox:

  설치: 60.2.0esr~linuxmint1+betsy

  후보: 60.2.0esr~linuxmint1+betsy

  버전 테이블:

 *** 60.2.0esr~linuxmint1+betsy 700

        700 http://packages.linuxmint.com cindy/upstream i386 Packages


9986D33F5BA0736428


--


Firefox ESR


우분투에서도 그러하듯, Firefox 패키지는 리눅스민트에서 항상 자기네들이 따로 만든 버전을 사용해왔는데요.

우분투에서는 우분투의 Firefox보다 리눅스민트의 Firefox의 우선 순위를 올리는 방식으로 해왔습니다.

물론, 그 우선 순위를 우분투보다 내리거나, 우분투와 우선 순위를 똑같이 만드는 방법을 통해 리눅스민트의 Firefox가 아닌, 우분투의 Firefox를 쓰는 방법이 있으며, 제가 주로 쓰고 있습니다^^;;


다음은 데비안에서 제공하는 Firefox ESR입니다.

원래 데비안에서 Firefox를 설치하려면 다음의 패키지뿐입니다.

LMDE 3 Cindy는 데비안 기반이지만, Firefox라는 이름의, 리눅스민트에서 만든 패키지가 따로 추가된 것이죠.


firefox-esr:

  설치: 60.2.0esr-1~deb9u2

  후보: 60.2.0esr-1~deb9u2

  버전 테이블:

 *** 60.2.0esr-1~deb9u2 500

        500 http://security.debian.org stretch/updates/main i386 Packages


어차피 둘 다 버전이 같기 때문에, 둘 중 어느 것을 쓰더라도 무방합니다만,

우분투 vs 리눅스민트, 데비안 vs LMDE에서 Firefox의 업데이트 속도는 당연히 전자들이 빠릅니다.

그래서 저는 우분투의 Firefox, 그리고 LMDE 3 Cindy에서는 데비안의 Firefox ESR을 씁니다.


터미널에서 다음과 같은 명령어를 통해, LMDE 3 Cindy에서 리눅스민트의 Firefox를 삭제하고, 데비안의 Firefox ESR 로 변경할 수 있습니다.


$ sudo apt-get update

$ sudo apt-get install firefox-esr firefox-esr-l10n-ko

$ sudo apt-get remove --purge firefox firefox-l10n-*


996F3D3D5BA074E617


--


WineHQ


LMDE 3 Cindy에서는 WineHQ의 Stretch 저장소가 존재합니다.

따라서 WineHQ에서 나온 Wine 프로그램을 사용할 수 있습니다.


$ sudo dpkg --add-architecture i386

$ wget -nc https://dl.winehq.org/wine-builds/Release.key

$ sudo apt-key add Release.key

$ rm -v Release.key


$ sudo nano /etc/apt/sources.list.d/official-package-repositories.list

에서 다음을 추가합니다. 그리고 컨트롤 + O를 누른 후 엔터를 쳐서 저장하고, 컨트롤 + X를 눌러 닫습니다.

LMDE 3 Cindy는 데비안 9 Stretch에 기반하기 때문에, 아래와 같이 stretch가 들어가야 하죠.

deb https://dl.winehq.org/wine-builds/debian/ stretch main


데비안 8에서는 WineHQ와 같이 HTTPS를 쓰는 저장소를 불러오기 위해서는 다음의 패키지가 필요했습니다.

데비안 9 기반의 LMDE 3 Cindy에서는 기본적으로 설치되어 있지만, 혹시 모르니 한 번 더 확인합니다.

$ sudo apt-get install apt-transport-https


이제 안정판은 다음과 같이 설치합니다.

$ sudo apt-get update

$ sudo apt-get install --install-recommends winehq-stable


안정판이 아닌 개발판은 다음과 같이 설치합니다.

$ sudo apt-get update

$ sudo apt-get install --install-recommends winehq-devel


--


SMPlayer (Qt4)


리눅스 사용자는 SMPlayer 17.10 버전부터 MPV를 업데이트해야 합니다.

기존 배포판들이 가지고 있는 MPV는 너무 구버전이라서 쓸 수가 없다고 합니다.

적어도 0.15 버전 이상의 mpv가 필요하다고 하는데, LMDE 3 Cindy의 mpv는 0.27 버전으로 꽤 높네요.


먼저, 터미널에서 우분투의 PPA 저장소를 가져와 추가하고 mpv를 설치합니다.

다만, 데비안에서는 PPA를 쓰기 위하여 다음의 패키지가 필요합니다. LMDE 3도 역시 필요하겠죠.

$ sudo apt-get install -y python-software-properties software-properties-common


이제 SMPlayer (Qt4)의 PPA에 있는 우분투 Bionic 저장소를 아래와 같이 설치합니다.

다른 패키지들과 달리 의존성 문제가 발생하지 않아서 좋네요.

$ sudo add-apt-repository "deb http://ppa.launchpad.net/rvm/smplayer/ubuntu bionic main"

$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A7E13D78E4A4F4F4


이제 mpv를 설치하고 SMPlayer (Qt4) 패키지들을 다음과 같이 설치하면 됩니다.

$ sudo apt-get install mpv

$ sudo apt-get install smplayer smtube smplayer-themes


--


WPS 오피스 [中國産]


다음의 내용은 wps-office_10.1.0.5707_a21 및 그 이하 버전에 해당되는 내용입니다.

2018년 9월 11일에 업데이트된 wps-office_10.1.0.6757 버전에는 해당되지 않습니다.


LMDE 3 Cindy에서는 WPS 오피스 설치시 libpng12-0 패키지 의존성 문제가 발생합니다.

LMDE 3 Cindy에 libpng12-0 패키지가 아예 없기 때문에 발생하는 문제입니다.

아울러 우분투 18.04 LTS 및 리눅스민트 19에서도 이 패키지가 존재하지 않아 같은 문제가 발생합니다.


다만, 데비안 8 Jessie에서 이 패키지를 마지막으로 지원하기에 그것을 받아 설치하면 의존성 문제가 해결됩니다.

( https://tracker.debian.org/pkg/libpng )


64비트

http://ftp.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb


32비트

http://ftp.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_i386.deb


우분투 16.04 LTS에서도 이 패키지를 마지막으로 지원하고 있으며, 이것을 받아 설치해도 의존성 문제가 해결됩니다.

아무래도 버전이 높은 우분투 패키지를 이용하는 것이 좋을 것으로 보입니다.

( https://launchpad.net/ubuntu/+source/libpng )


64비트

https://launchpad.net/ubuntu/+archive/primary/+files/libpng12-0_1.2.54-1ubuntu1_amd64.deb


32비트

https://launchpad.net/ubuntu/+archive/primary/+files/libpng12-0_1.2.54-1ubuntu1_i386.deb


--


Bleachit


Bleachit는 LMDE 3 Cindy를 지원하고 있습니다.

따라서 https://www.bleachbit.org/download/linux 에서 Debian 9 (Strech)을 찾으면 됩니다.


--


686 PAE 커널


이 부분은 32비트로 설치한 LMDE 3 Cindy에서만 겪는 문제입니다.


LMDE 3 Cindy의 기반이 되는 데비안은 오래된 시스템을 계속하여 지원하기 위하여, 데비안 8에서는 586 커널을 기본으로, 데비안 9부터는 686 커널을 기본으로 두되 586 커널도 함께 두는 방식으로 하고 있습니다.

문제는 이런 커널이 기본으로 되어 있다보면 멀티코어 지원 문제가 발생합니다.


즉, 자신의 PC가 1990년대에서 2000년대 사이에 나온 펜티엄4 이하가 아닌 이상, 위와 같은 커널이 기본으로 되어 있다면 CPU 코어가 2~4개인데 그 중 1개만 인식되는 문제가 있습니다.


그래서 현존하는 멀티코어 하드웨어의 32비트 리눅스에서는 686 PAE 커널이 필요합니다.

리눅스민트의 기반이 되는 우분투에서는 우분투 12.04 LTS 이후로 위 커널만 지원하고 있습니다.


 * LMDE 2 / 데비안 8 32비트에서 멀티코어(쓰레드)가 작동하지 않을 때 : http://la-nube.tistory.com/30


한편, LMDE 3 Cindy, 그 중에서도 32비트 버전에서는 다음과 같은 명령어를 통해 686 PAE 커널을 설치하고, 재부팅 후 686 커널과 586 커널을 삭제하는 작업이 필요합니다.

$ sudo apt-get install linux-headers-686-pae linux-image-686-pae


재부팅 후, 터미널에 다음의 명령어를 입력합니다.

$ sudo apt-get remove --purge linux-headers-586 linux-headers-686 linux-image-686 linux-headers-4.9.0-*-686 linux-image-4.9.0-*-686


--



출처: http://la-nube.tistory.com/478 [la Nube | 라 누베]

번호 제목 글쓴이 날짜 조회 수
공지 [공지] '하모니 소식' 게시판 변경 공지 LukeHan 2018.12.17 1
1463 [건의] 커뮤니티 게시판 개편안 [2] update krhamoni 2018.12.17 19
1462 Firefox 원격코드 실행 취약점 보안 업데이트 권고 [2] la_Nube(누베) 2018.12.12 65
1461 HamoniKR-ME 설치진행 오류 문의 [2] lookhim 2018.11.29 231
1460 하모니카 HamoniKR-ME 1.1 버전 업데이트 [2] la_Nube(누베) 2018.11.20 317
1459 우분투 18.04 LTS가 5년 지원에서 10년 지원으로 [7] la_Nube(누베) 2018.11.20 344
1458 하모니카의 새로운 버전이 나왔습니다! HamoniKR-ME [2] la_Nube(누베) 2018.11.19 314
1457 VirtualBox 제로데이 취약점 발견한 연구원, 오라클에 제보하지 않은 채 공개해 [2] la_Nube(누베) 2018.11.08 263
1456 대부분의 리눅스 배포판에 영향을 미치는 새로운 권한 상승 취약점 발견 la_Nube(누베) 2018.10.30 308
1455 오늘 민트19 이곳에서 다운받아 설치 했습니다. [1] 가림토 2018.10.24 358
1454 만자로와 우분투 [8] WDever 2018.10.23 601
1453 LibSSH 라이브러리 보안 업데이트 권고 [4] la_Nube(누베) 2018.10.19 227
1452 정부에서 했으면 하는 것. [1] 세벌 2018.10.17 218
1451 동영상 가이드 게시판이 있으면 좋을 것 같습니다. [2] 행복한펭귄 2018.10.08 162
1450 좋은 소식?? [2] 식혜고양이 2018.10.07 270
1449 하모니카리눅스에서 주민등록등본 출력 되나요? [9] 세벌 2018.10.02 513
1448 민트 쥐돌이 타라 가이드 앤 팁 [1] Ohnine 2018.09.27 258
» LMDE 3 Cindy (데비안 9 기반)를 써보았습니다! [2] la_Nube(누베) 2018.09.18 330
1446 앱이미지파일 [1] 보리 2018.09.16 132
1445 파이어폭스의 북마크 기능이 말썽입니다. [3] 블랙커피 2018.09.10 210
loginbox
아직 회원이 아니세요? MEMBER JOIN