자유게시판

조회 수 903 추천 수 0 댓글 7
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄

 안녕하세요. 저는 만화가 울림입니다. 아직은 지식이 얕아 도움을 주기보다는 받는 일이 많네요...

 

 원래는 하모니카 소프트웨어 관리자에서 snes9x를 다운 받으려고 했었는데, 이게 실행시켜도 아무것도 안 뜨더라구요.

 

 그래서 마이쮸 가이님이 올리셨던 레트로 아크를 설치하려고 했는데요. 다음과 같은 문구가 출력되었습니다.

 

LSB codename: 'uma'.

Version of base-files: '20.2.0hamonikr9'.

Your LSB codename isn't a valid Linux Mint codename.

Please check your LSB information with "lsb_release -a".

 
 그래서 시킨대로 lsb_release -a 명령어를 입력한 결과는
 
No LSB modules are available.
Distributor ID: Hamonikr
Description: HamoniKR 5.0 Hanla
Release: 5.0
Codename: uma
 
 흠... 저 LSB 모듈이 어떤 뜻인가요? 혹시 snes9x 가 설치만되고 실행이 안되었던 것도 이 문제 때문일까요? 고수님들의 작은 도움 부탁드립니다.
 제 문제 함께 고민해주셔서 감사드려요. 코로나 조심하시고 좋은 하루 되시길! ^0^/
  • ?
    마이쮸가이 2022.02.21 05:52

    아래 명령어로 lsb를 설치하고 다시 한번 실행해 보셔요.

     

    sudo apt-get install lsb-core

     

    설치과정 중 코드네임을 확인하고 그에 맞는 설치가 이루어지는데 해당 모듈이 없거나

    모종의 문제로 작동하지 않아서 그런 것 같습니다. 

     

  • ?
    만화가엄두 2022.02.22 02:19

     레트로 아크를 설치하는 명령어 sudo add-apt-repository ppa:libretro/stable && sudo apt-get update && sudo apt-get install retroarch 를 넣었더니 다음과 같은 (이전과 똑같은) 결과가 나왔습니다.

     

    LSB codename: 'uma'.

    Version of base-files: '20.2.0hamonikr9'.

    Your LSB codename isn't a valid Linux Mint codename.

    Please check your LSB information with "lsb_release -a".

     
    그리고 lsb_release -a 명령어의 결과는 다음과 같습니다. 뭔가 조금 달라졌습니다.
     
    LSB Version: core-11.1.0ubuntu2-noarch:security-11.1.0ubuntu2-noarch
    Distributor ID: Hamonikr
    Description: HamoniKR 5.0 Hanla
    Release: 5.0
    Codename: uma
     
     음... 그냥 운명이려니하고 넘겨야 겠네요. 매번 도와주셔서 감사합니다!
  • ?
    마이쮸가이 2022.02.22 05:45

    lsb_release -a  명령어로 하모니카의 버전과 릴리즈, 코드네임이 확인하셨으면

    다시

    sudo add-apt-repository ppa:libretro/stable && sudo apt-get update && sudo apt-get install retroarch

     

    명령어로 설치 시도를 해 보셨나요?

    엄두님이 저랑 비슷하게 4.0에서 소스리스트를 통해 업그레이드를 하신 케이스라

    릴리즈 확인하고 진행하시면 특별한 차이점이 있지 않는 한 설치가 될 것 같은데요.

     

    제가 같은 오류였지만 설치가 잘 완료 되었습니다.

     

    혹여 이전에 설치 중 오류로 인해 설치완료 되지 않은 프로그램이 존재할 가능성도 있으므로

     

    sudo dpkg --configure -a --force-all

     

    sudo apt-get autoremove

     

    sudo add-apt-repository ppa:libretro/stable && sudo apt-get update && sudo apt-get install retroarch

     

    순으로 진행해 보시는 것을 추천 드립니다.

     

  • ?
    만화가엄두 2022.02.24 22:49

     항상 어려운 요청에도 시간내어 답변해주시는 마이쮸가이님께 감사인사 먼저 드리며 댓글 답니다. ^^

     sudo dpkg --configure -a --force-all 명령에서부터 오류가 나더라구요. 이건 하모니카 5.0 업데이트 때부터 계속 나오던 메시지인데

     

    crosswebex (3.3.2-8) 설정하는 중입니다 ...

    Check Module Integrity...

    /usr/share/crosswebex/lib/check_module: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

    dpkg: error processing package crosswebex (--configure):

     installed crosswebex package post-installation script 서브프로세스가 오류 종료 상태 127를 반환했습니다

    처리하는데 오류가 발생했습니다:

     crosswebex

     
    ... 저 '서브프로세스가 오류 종료 상태 127를 반환했습니다' 라는 익숙한 메시지와 함께 리타이어...
    여러모로 신경써주셨는데 아무래도 안되는 것 같습니다. 그래서 그냥 집에서 노는 스마트폰 하나 커롬 올린다음에 에뮬머신으로 쓰려구요.
    이렇게 다른 길을 개척해보라는 리눅스신의 뜻으로 알고 살렵니다.
     언제나 건강 조심하시고, 좋은 하루 보내세요 마이쮸가이님!! ^^/
  • ?
    마이쮸가이 2022.02.25 07:12

    crosswebex 면 공인인증서 관련 보안프로그램인데 아마도

    업그레이드 이전에 '환영합니다'를 통해 사이트 호환성 설치를 하신 것으로 추측 됩니다.

     

    에러 이후에도 공인인증서 사용이 가능하다면 크게 문제될 여지는 없어 보이나

    이후 패키지 설치시에 계속 오류 때문에 문제로 남을 가능성이 많고

     

    보통 에러코드 127은 해당 모듈이나 스크립트를 지정한 자리에서 찾을 수 없어

    설치를 중단함으로 개인적인 생각이지만 업그레이드가 도중에 멈췄을 가능성이 큰 것 같습니다.

    시간이 될 때 해당 오류를 해결하는 것을 추천 드리고 싶네요.

     

    일단 공인인증서를 백업하신 후

     

    1. 프로그램 메뉴 > 기본설정 > 환영합니다 실행, 사이트 호환성 설치를 다시 진행 후

       터미널을 열고 sudo apt update && sudo apt upgrade  실행

     

    해결이 되지 않았다면 

     

    2. 터미널을 열고 (순서대로 진행하며 오류 해결을 시도합니다.) 

     

    sudo apt-get install --reinstall

     

    sudo apt install -f

     

    sudo dpkg --configure -a

     

    sudo dpkg --configure -a --force-all

     

    해결이 되지 않았다면 오류나는 패키지를 강제로 삭제합니다.

     

    3. 터미널을 열고 (삭제가 안될 시 위에서 아래 순으로 순차적으로 시도합니다.)

     

    sudo apt-get autoremove --purge crosswebex

     

    sudo dpkg --remove --force-remove-reinstreq crosswebex

     

    3번까지 마치셨으면 다시 아래 명령어로 불필요한 파일들을 지워주고 재부팅하여

    이전에 실패한 업그레이드를 계속합니다.

     

    sudo apt clean && sudo apt autoremove && reboot

     

    재부팅이 되었으면 아래 명령어로 업그레이드를 시도 합니다.

     

    sudo apt update && sudo apt dist-upgrade

     

     

    PS: 해결이 되셔야 할텐데.... 제가 아는 것은 여기까지네요. :)

     
  • ?
    Moordev 2022.02.22 10:17
    제 예상입니다만 snes9x 설치프로그램이 최신 리눅스민트 코드네임을 인식못 한듯 합니다. uma라는건 리눅스민트20.2를 의미하는건데 인식을 못하는것이지요.

    /etc/os-release 파일을 임시로 수정해서 리눅스민트 구버전으로 인식시킨뒤 (Ulyana같은) 진행하면 될것 같습니다.

    제일좋은건 snes9x설치할때 uma를 인식하는거겠지요.
  • ?
    만화가엄두 2022.02.24 22:55

     말씀해주신대로 코드네임을 Ulyana로 바꾼뒤 깔아봤는데요. 역시 설치는 잘 되는데, 실행할 때 아무것도 뜨지 않습니다. 뭔가 다른 문제가 있나봐요.

     다른 길을 찾으라는 리눅스 신의 뜻으로 알고, 옛 폰에 커롬 올려서 에뮬머신으로 쓰는 방법을 연구중입니다.

     어려운 부탁에도 언제나 함께 고민해주시는 Moordev님께 감사드립니다. 환절기 코로나 조심하시고, 좋은 하루 되시길! ^0^/


List of Articles
번호 제목 추천 수 글쓴이 날짜 조회 수
1244 한성 놋북 쓰면서 느낀점 2 0 다찌마와 2022.05.17 647
1243 jpg파일 pdf변환 방법 3 0 해중이 2022.05.16 579
1242 블루투스 키보드 먹통 해결 방법에 대해 질문드립니다. 1 0 잘몰라요. 2022.05.14 609
1241 갤버즈2 사용중인데 1 0 다찌마와 2022.05.12 552
1240 안녕하세요 가입인사 드립니다. 1 0 해일군 2022.05.11 550
1239 안녕하세요~ 1 0 어리굴젓 2022.05.11 592
1238 [무료교육] [한컴아카데미] IoT 센서활용 플랫폼 구축을 위한 임베디드 SW개발자 교육생 모집 file 0 한컴아카데미 2022.05.11 579
1237 가입인사 올립니다. 0 다찌마와 2022.05.11 528
1236 이동형 불루투스 테이블 0 잘몰라요. 2022.05.09 545
1235 가입인사 드립니다. ^^ 2 0 하늘가 2022.05.08 551
1234 2022. 성남 메타버스 청년채용박람회 정보 0 밀크 2022.05.06 536
1233 도메인 질문 2 0 해중이 2022.05.06 518
1232 노트북 추천좀 해주세요 5 0 홍쿠주 2022.05.03 1516
1231 노이즈캔슬링 이어폰 5 0 홍쿠주 2022.05.03 582
1230 서버관리 1 0 해중이 2022.04.25 580
1229 리눅스용 북스캔앱, OCR 앱 좋은 거 있나요? 2 0 해인 2022.04.22 699
1228 블루투스도 1 0 두다모 2022.04.20 576
1227 [무료컨퍼런스] 캐치 커리어콘 #메타버스편 사전 신청중 (~4/28) file 0 캐치 2022.04.18 565
1226 메타버스 취업 0 해중이 2022.04.17 577
1225 메타버스 상용화 1 0 maama 2022.04.13 584
Board Pagination Prev 1 ... 27 28 29 30 31 32 33 34 35 36 ... 94 Next
/ 94
CLOSE