자유게시판

안녕하세요. 리눅스를 잘 모르지만 설치하고 사용하며 경험하고 있는 초보입니다. 이번에 데비안 testing 버전을 설치하고 한글 입력기로 nimf를 사용하려 하는데 에러가 발생하여 질문드립니다.

(uname -a: Linux debian 4.19.0-5amd64 #1 SMP Debian 4.19.37-5 (2019-06-19) x86_64 GNU/Linux)


https://gitlab.com/nimf-i18n/nimf/raw/master/README


위에 나오는 대로 따라하여 debuild까지 진행하였습니다. debuild 이후에 에러까지 출력된 것을 https://dpaste.de/pmur에 올려놨습니다.


dpkg-shlibdeps: warning: can't extract name and version from library name 'libnimf-m17n.so'


이 부분이 많이 반복되서 문제가 있는 것 같은데 해당 부분을 검색해서 나오는 글들을 봐도 잘 모르겠습니다. 그리고


Now signing changes and any dsc files...
signfile dsc nimf_2019.07.16.dsc Hodong Kim <cogniti@gmail.com>
gpg: keybox '/home/deb/.gnupg/pubring.kbx' created
gpg: skipped "Hodong Kim <cogniti@gmail.com>": No secret key
gpg: /tmp/debsign.fVDu8Hw9/nimf_2019.07.16.dsc: clear-sign failed: No secret key
debsign: gpg error occurred! Aborting....
debuild: fatal error at line 1112:
running debsign failed


이 부분이 중요한 것 같은데 gpg 관련 에러가 발생하는 것 같습니다. GPG(무엇인지 잘 모릅니다.)가 개발자 고유의 키 같은데 그게 없어서 발생하는 것일까요? gpg --list-secret-keys와 gpg --list-keys를 했을 때 아무것도 나오지 않습니다. abort가 되어도 deb 파일들은 생겨서 sudo dpkg -i로 설치를 했습니다. 제대로 실행은 되는데 한/영 변환이 되지 않습니다. abort 되면서 문제가 있어서 한/영 전환이 안 되는 것인지 아니면 저 오류 메시지는 무시해도 되지만 제가 설정을 잘못해서 안 되는 것인지도 파악이 안 됩니다. 의존성 검사 후에 버전이 몇 이상이여야 한다고 나오는데 의존성 설치시에 버전이 몇인지 확인하지 않았습니다. 이것도 문제가 될 수 있을까요? 혼자서 해결하려고 노력했지만 해결하지 못하여 질문드립니다. 리눅스의 세계에 안착할 수 있도록 도움 부탁드립니다!

번호 제목 글쓴이 날짜 조회 수
572 시리즈:내 리눅스가 이렇게 쉬울 리 없어! [1] 펭귄들의행진 2020.03.27 483
571 리눅스,우분투터치OS가 돌아가는 PINE폰! 펭귄들의행진 2020.03.27 287
570 사지방 하모니카에 USB관련 궁금한게있는데요 [1] RyK 2020.03.26 381
569 Kde Connect 꼭 까세요, 두 번 까세요. [1] SaintTail 2020.03.25 432
568 Proton 생각보다 좋네요. [4] SaintTail 2020.03.24 500
567 제로페이 전용앱으로 쓸만한 심플한 페이앱이 나와ㅆ네요~ 커니모하 2020.03.24 107
566 국가보훈처 사이트 회원가입이안돼여 [2] 남사장 2020.03.22 179
565 microsoft silverlight 호환이 안됩니다. [2] 전민전 2020.03.21 263
564 telegram [4] SaintTail 2020.03.19 424
563 설치가 안되는 것 같습니다ㅠ 도와주세요ㅠ [3] Goodsims 2020.03.18 289
562 시작화면 오류 내용에 대한 질문 Kevin 2020.03.18 59
561 폰트 깨짐현상에 대해서 묻고싶습니다. [2] file 라루미 2020.03.08 322
560 일부 프로그램에서 한글 입력이 되지 않는 문제가 있습니다. [2] jun 2020.03.06 348
559 카카오톡 사진 짤림현상 [2] 라루미 2020.03.06 989
558 lutris로 게임을 깔고있는데 어떻게 해야할지 모르겠어요 도와주세요 [1] 라루미 2020.03.05 339
557 명령어 발동이 안됩니다.. 도와주세요 [1] file 라루미 2020.03.05 181
556 하모니카 좋네요! [3] 동네노는이장 2020.03.05 439
555 유튜브 추천합니다. [2] neti 2020.03.05 291
554 스팀에서 리눅스지원 안되는게임을 할수있는 방법은 없을까요? [9] 라루미 2020.03.04 471
553 와인5.0의 기반으로 카카오톡을 설치하는 방법이나 링크가 있다면 공유부탁드립니다. [2] 코드메이커 2020.03.03 1114
  • 하모니카 미디어 에디션
  • 설치가 필요없는 화상통화 하모니
loginbox
아직 회원이 아니세요? 회원가입