공격자들이 리눅스 컨테이너를 탈출해 호스트의 루트 권한을 탈취할 수 있는 RunC 결점 발견

RunC Flaw Lets Attackers Escape Linux Containers to Gain Root on Hosts

CVE-2019-5736


이스트시큐리티 알약 블로그 : https://blog.alyac.co.kr/2124


runC 컨테이너 코드에서 오픈소스 컨테이너 관리 시스템 다수에 영향을 미치는 심각한 보안 취약점이 발견 되었습니다. 이는 공격자들이 리눅스 컨테이너를 탈출하고 호스트 OS의 승인 되지 않은 루트 수준의 접근 권한을 얻을 수 있도록 허용합니다.


Docker에서 만든 runC는 Docker, Kubernetes, ContainerD, CRI-O 및 기타 컨테이너 의존 프로그램의 디폴트 컨테이너 런타임이며 많은 주요 클라우드 호스팅 및 서버 제공자들이 사용하고 있습니다.


Debian과 Ubuntu는 그들의 리눅스 배포판이 이 결점에 취약하다는 것을 인정했습니다. 이 문제는 LXC, Apache Mesos 컨테이너 코드를 사용하는 컨테이너 시스템에도 영향을 미칩니다.


-본문 중 일부




<Debian>


데비안 9 Stretch (Stable) // LMDE 3 Cindy

 - lxc : 최신 버전인 1:2.0.7-2+deb9u2 는 취약하며, 아직 보안 패치가 없음 (vulnerable)

 - runc : 최신 버전인 0.1.1+dfsg1-2 는 취약하며, 아직 보안 패치가 없음 (vulnerable)


데비안 8 Jessie (OldStable) // LMDE 2 Betsy

 - lxc : 최신 버전인 1:1.0.6-6+deb8u6 은 취약하며, 아직 보안 패치가 없음 (vulnerable)

 - runc : 패키지가 존재하지 않아 해당 사항이 없음


https://security-tracker.debian.org/tracker/CVE-2019-5736




<Ubuntu>


우분투 18.04 LTS // 리눅스민트 19.x

 - docker.io : 보안 패치가 완료된 18.06.1-0ubuntu1.2~18.04.1 버전이 배포됨 (released)

 - runc : 보안 패치가 완료된 1.0.0~rc4+dfsg1-6ubuntu0.18.04.1 버전이 배포됨 (released)


우분투 16.04 LTS // 리눅스민트 18.x

 - docker.io : 보안 패치가 완료된 18.06.1-0ubuntu1.2~16.04.1 버전이 배포됨 (released)

 - runc : 보안 패치가 완료된 1.0.0~rc2+docker1.13.1-0ubuntu1~16.04.1 버전이 배포됨 (released)


우분투 14.04 LTS // 리눅스민트 17.x

 - docker.io : 최신 버전인 1.6.2~dfsg1-1ubuntu4~14.04.1 은 취약하며, 아직 보안 패치가 없음 (needed)

 - runc : 패키지가 존재하지 않아 해당 사항이 없음


※ 하모니카와 하모니카 커뮤니티 배포판은 각각 리눅스민트 버전에 맞추면 됩니다.


https://people.canonical.com/~ubuntu-security/cve/2019/CVE-2019-5736.html




보안 패치를 적용하기 위해서는 터미널에 다음과 같이 입력합니다.


<데비안과 우분투>


$ sudo apt-get update

$ sudo apt-get dist-upgrade



<리눅스민트와 하모니카>


$ sudo apt-get update

$ sudo apt-get dist-upgrade

$ sudo mintupdate-cli upgrade



출처: https://la-nube.tistory.com/543 [la Nube | 라 누베]
번호 제목 글쓴이 날짜 조회 수
공지 [공지] '하모니 소식' 게시판 변경 공지 [1] LukeHan 2018.12.17 216
1493 VLC플레이어 세팅된 "창을 항상위에" 가 자꾸 풀립니다...다른분도 그런가요? [4] 신성 2019.03.17 135
1492 민트리눅스 19.1 사용하고 있습니다. 화면이 버벅임이 있는데요..해결방안좀 부탁드립니다. [9] 신성 2019.03.15 361
1491 리눅스민트 사용하기 시작했습니다. [11] 혼지거 2019.03.14 332
1490 김프가 리다이렉팅 되요. [5] cancaodosang 2019.03.14 126
1489 예상치 못하게 우분투 16.04.6 LTS 출시돼 [3] la_Nube(누베) 2019.03.12 261
1488 MX Linux 설치...유튜브전용 [1] 프리 2019.03.12 303
1487 [질문] 브레이브 브라우저로 인한 업데이트 에러 [5] 관우 2019.03.10 139
1486 트레이 캡쳐 file cancaodosang 2019.03.10 54
1485 MX Linux도 좋긴 하네요. 하지만... [6] 경은 2019.03.07 642
1484 우분투 서버 nginx webdav 한글 깨짐오류 질문 [7] 경은 2019.03.05 168
1483 HamoniKR-ME 64bit 1.2 간단 사용기 [2] file seo 2019.03.02 381
1482 하모니카 한글 안됨 [8] cancaodosang 2019.03.01 254
1481 HamoniKR-ME 삭제하고 윈도우 깔고 싶은데요.. [2] wonjoo 2019.02.27 184
1480 하모니카 OS 업데이트에 대해 궁금합니다 [6] seo 2019.02.26 296
» 공격자들이 리눅스 컨테이너를 탈출해 호스트의 루트 권한을 탈취할 수 있는 RunC 결점 발견 [1] la_Nube(누베) 2019.02.24 114
1478 MX linux18로 리눅스에 입문했어요~~ [6] saltman 2019.02.22 409
1477 리눅스민트 19.1 원격접속 질문 file 포토슬럼프 2019.02.20 122
1476 공격자들이 리눅스 시스템에서 루트 권한을 얻을 수 있는 Snapd 결점 발견 [1] la_Nube(누베) 2019.02.19 106
1475 리눅스 민트 카카오톡 한글깨짐 현상 문의 [4] file 민트유저 2019.02.15 557
1474 [질문] 민트리눅스 19.1 버전 사용중입니다. 윈도우로 원격 접속 때문에 문의 드립니다. [2] June1046 2019.02.08 279
loginbox
아직 회원이 아니세요? MEMBER JOIN