하모니카 묻고답하기

조회 수 860 추천 수 0 댓글 8
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄 첨부
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄 첨부

스크린샷, 2022-02-28 00-08-01.png

 

오늘 하모니카를 저의 노트북에 설치를 했습니다.

Python 최신버전 3.10.2 버전을 다운받아 컴파일 하는 과정에 아래와 같은 에러가 뜹니다.

확인해보면 GCC는 이미 설치되어 있는 상태입니다.

 

무슨문제 일까요?

  • ?
    마이쮸가이 2022.02.28 02:51

    sudo를 빼고 진행해 보셔요.

     

    ./configure

     

    make

     

    make test

     

    sudo make install

     

     

     
  • profile
    빅파이프 2022.02.28 08:32

    문제는 동일합니다.

  • ?

    일단 하모니카 5.0을 사용하고 커널이나 다른 것은 손 댄 것이 없는 제 노트북에 잘 설치가 된 것으로 보아

    빅파이프님과 저의 차이는 아마도 빌드에센셜 업데이트 유무일 것 같습니다. 

    아래 명령어로 설치한 이후에 진행해 보셔요.

     

    sudo apt update && sudo apt upgrade -y

     

    sudo apt install build-essential zlib1g-dev libncurses5-dev libgdbm-dev libnss3-dev libssl-dev libreadline-dev libffi-dev libsqlite3-dev wget libbz2-dev -y

     

    설치가 완료 되었으면

     

    ./configure --enable-optimizations

     

    make -j 2           ### 숫자 2는 사용할 CPU 코어 수, 본인에 맞는 숫자로 변경하셔요.


    sudo make altinstall

     

    python3.10 --version      ### 버전체크

    제목 없음.png

     

     

     

     

     

     

     

  • ?
    유리 2022.02.28 13:36

    최신 버전이 꼭 필요한 상황인가요? 소스 설치가 데비안 계열에서 대체로 바람직하지 않습니다.

    꼭 설치할 필요가 있다면, 빌드 환경은 아래와 같이 만들어질 수 있습니다:

     

    sudo apt-get build-dep python3-defaults

  • profile
    빅파이프 2022.02.28 13:49

    무조건 최신버전을 사용해야 할 필요는 없습니다.

    그냥 개인적으로 모든 프로그램을 최신버전으로 유지하려는 강박증 같은것이 있어서요.

    python3.7 이상 버전이면 충분합니다.

  • ?
    유리 2022.02.28 14:40

    바이너리 패포판은 패키지 관리자가 만들어준 것이 대체로 가장 좋습니다.

    필요에 따라 개인이 패키지를 만들어서 쓸 수도 있지만, "필요성"이 있어야 합니다.

    아래와 같이 저장소에 있는 것을 설치하십시오.

    sudo apt install python3

  • profile
    빅파이프 2022.02.28 14:42

    답변 감사드립니다.

  • ?
    세벌 2022.03.05 18:22

    See config.log for more details

    라고 나오네요.

    config.log 파일에 힌트가 있을 거 같네요.


List of Articles
번호 제목 추천 수 글쓴이 날짜 조회 수
공지 게시판에 질문하기 전 읽기 - 어떻게 질문을 하는 것이 좋을까? 1 0 Kevin 2019.11.18 13009
836 mpv 그래픽 3 0 Ohnine 2017.12.30 867
835 하모니카도 여기에 등재되는날이 오면 좋겠네요 2 0 민트초코너무좋아 2020.06.29 866
834 라이선스 중복문제. 1 0 민간인28호 2021.04.02 864
833 Boot-select 시간도 설정가능하게 부탁드립니다. 1 0 자유의지 2020.01.21 864
832 많은 분들의 답변 감사드리고 사과드립니다. 6 0 galisany 2020.06.19 863
831 CVE-2017-3737 : OpenSSL Read/write after in error state 취약점 1 0 la_Nube 2017.12.12 862
830 키보드 입력 문제가 발생했습니다. 2 0 머털도사 2020.06.07 861
829 하모니카에서 (EBSi를 제외한) 인터넷 강의를 들을 수는 없을까요? 4 0 제이산화구리 2023.12.15 860
» Python 설치시 에러가 뜹니다. 8 file 0 빅파이프 2022.02.28 860
827 커널 5.0의 장점이 뭘까요? 2 0 iloveapink 2019.08.22 860
826 리눅스 커널 5.0.8 미만에서 RCE 취약점 발견됨 1 0 la_Nube(누베) 2019.05.21 860
825 하모니카_테사를 사용하고 있습니다.. 폰트설치.. 변경은 어떻게 하는것인가요? 9 0 신성 2019.03.25 860
824 (무선랜) 도움 바랍니다. 4 file 0 시트콤처럼 2022.04.14 857
823 안녕하세요 USB2.0은 모두 작동을 않하네요 6 0 그레이독 2021.11.09 856
822 우분투(Ubuntu) LTS 리눅스 커널 업데이트 - 4.15.0-29 5 0 la_Nube(누베) 2018.07.23 856
821 현재 커뮤니티 배포판에 등록된 18.3 xfce 32비트에 관하여... 3 0 Moordev 2018.01.04 855
820 번역은 어려워... 9 0 세벌 2018.01.12 854
819 인텔 관련 이슈 8 0 변신 2018.01.03 854
818 하모니카 서버이전을 알려드립니다. 12 0 Kevin 2018.02.06 853
817 죄송하지만 슬랙 채팅참여 안 되네요. 1 0 화난행성 2019.12.01 851
Board Pagination Prev 1 ... 77 78 79 80 81 82 83 84 85 86 ... 123 Next
/ 123
CLOSE