하모니카 묻고답하기

?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄

공격자들이 리눅스 시스템에서 루트 권한을 얻을 수 있는 Snapd 결점 발견

Snapd Flaw Lets Attackers Gain Root Access On Linux Systems

CVE-2019-7304


이스트시큐리티 알약 블로그 : https://blog.alyac.co.kr/2126


우분투와 및 기타 리눅스 배포판들에서 심각한 권한 상승 취약점이 발견 되었습니다. 이 취약점은 로컬 공격자나 악성 프로그램이 타겟 시스템에서 루트 권한 및 전체 제어 권한을 얻을 수 있도록 허용합니다.


이 취약점은 “Dirty_Sock”이라 명명되었으며 CVE-2019-7304로 등록되었고, 이를 발견한 보안 연구원인 Chris Moberly는 지난달 말 우분투의 제작사인 Canonical에 제보했습니다.


Canonical이 제작한 snapd는 우분투의 모든 버전에 디폴트로 설치 되어 있으며 Debian, OpenSUSE, Arch Linux, Solus, Fedora를 포함한 다른 리눅스 배포판에서도 사용 되고 있습니다.


-본문 중 일부




리눅스 snapd 취약점(dirty sock) 보안 업데이트 권고

CVE-2019-7304


한국인터넷진흥원 : https://www.krcert.or.kr/data/secNoticeView.do?bulletin_writing_sequence=34955


□ 개요

 o 리눅스의 snap 데몬에서 권한상승 취약점(dirty sock)을 해결한 보안 업데이트 발표

 o 악용코드가 공개되어 있으므로 영향 받는 버전을 사용 중인 이용자는 해결방안에 따라 적극적인 업데이트 필요

  ※ snap 패키지 : 소프트웨어 설치 및 제거를 쉽게 사용할 수 있도록 사용자 편의를 지원하는 서비스 패키지


□ 설명

 o snapd API에서 UNIX 소켓에 대한 접근 통제가 미흡하여, 공격자가 해당 API에 접근하여 관리자 권한을 탈취할 수 있는 권한상승 취약점(CVE-2019-7304)


-본문 중 일부




<Debian>


데비안 9 Stretch (Stable) // LMDE 3 Cindy

 - snapd : 보안 패치가 완료된 2.21-2 버전이 배포됨 (fixed)


데비안 8 Jessie (OldStable) // LMDE 2 Betsy

 - 패키지가 존재하지 않아 해당 사항이 없음


https://security-tracker.debian.org/tracker/CVE-2019-7304




<Ubuntu>


우분투 18.04 LTS // 리눅스민트 19.x

 - snapd : 보안 패치가 완료된 2.34.2+18.04.1 버전이 배포됨 (released)


우분투 16.04 LTS // 리눅스민트 18.x

 - snapd : 보안 패치가 완료된 2.34.2ubuntu0.1 버전이 배포됨 (released)


우분투 14.04 LTS // 리눅스민트 17.x

 - snapd : 보안 패치가 완료된 2.34.2~14.04.1 버전이 배포됨 (released)


※ 하모니카와 하모니카 커뮤니티 배포판은 각각 리눅스민트 버전에 맞추면 됩니다.


https://people.canonical.com/~ubuntu-security/cve/2019/CVE-2019-7304.html




보안 패치를 적용하기 위해서는 터미널에 다음과 같이 입력합니다.


<데비안과 우분투>


$ sudo apt-get update

$ sudo apt-get dist-upgrade



<리눅스민트와 하모니카>


$ sudo apt-get update

$ sudo apt-get dist-upgrade

$ sudo mintupdate-cli upgrade



출처: https://la-nube.tistory.com/542 [la Nube | 라 누베]
  • profile
    행복한펭귄 2019.02.19 16:26
    Snapd에 보안 문제가 생겼군요.
    우분투 계열에서 기본적으로 널리 사용하는 패키지 관리 데몬에 문제가 있다니 문제네요.
    보안 패치 방법이 안내되었으니 다행입니다.

    이미지맵이나 플랫팩 등과 같은 곳에도 문제가 없는지 고밈이되네요.

    보안 문제는 항상 중요한지라...

List of Articles
번호 제목 추천 수 글쓴이 날짜 조회 수
공지 게시판에 질문하기 전 읽기 - 어떻게 질문을 하는 것이 좋을까? 1 0 Kevin 2019.11.18 12976
707 하모니카1.3 virtualbox 설치시 오류 2 0 짱구신 2019.05.26 762
706 좋은 소식?? 2 0 식혜고양이 2018.10.07 762
705 snap flatpak 3 0 Ohnine 2018.07.19 762
704 예상치 못하게 우분투 16.04.6 LTS 출시돼 3 0 la_Nube(누베) 2019.03.12 761
703 VirtualBox 제로데이 취약점 발견한 연구원, 오라클에 제보하지 않은 채 공개해 2 0 la_Nube(누베) 2018.11.08 761
702 CrossOver 17.5.0 출시 4 file 0 행복한펭귄 2018.05.09 761
701 [언어] BASIC 언어로 쉽게 누구든지 프로그래밍할 수 있습니다 1 0 행복한펭귄 2018.05.06 761
700 가상키보드 문의 2 file 0 chizeta 2020.06.09 760
699 [질문] comix 설치가 안됩니다. [Mint 19.1 Tessa 64bit] 5 0 관우 2019.01.31 760
698 화면보호기 설정은 없어진건가요? 3 0 빨리빨리 2020.02.17 759
697 댓글 모음에 표시되지 않는 게시판이 있으니 수정 바랍니다. 1 0 행복한펭귄 2017.12.12 758
696 리눅스 민트에서 내장 그래픽 사용하다가..ㅜㅜ 3 0 블랙커피 2022.01.03 757
695 하모니카 게시판이 아주 ㄱㅍ이네요 3 0 KongS 2023.06.07 756
694 허태준 - 가장 의미 있고 즐거운 개발 4 0 Kevin 2018.04.22 755
693 하모니카 5.0 에서 6.0으로 업그레이드 하면서..... 4 file 0 KongS 2022.12.07 753
692 하모니카 5 에서 nimf 사용중인데 한영키 오른쪽 alt 설정이 재부팅하면 다시 적용이 안됩니다. 10 0 Japser 2022.05.16 753
691 CentOS 7/6 리눅스 커널 업데이트 - 3.10.0-693.21.1.el7, 2.6.32-696.20.1.el6 1 0 la_Nube 2018.03.10 753
690 시냅틱 패키지 관리자 실행이 안됩니다.;;; 7 0 관우 2019.04.05 752
689 우분투 스냅스토어에서 멀웨어 숨겨진 패키지 발견 4 file 0 PEACH 2018.05.14 752
688 우분투20.04LTS 에서 wine 6.0 안정판을 설치하려고하는데 잘안됩니다. 0 라루미 2021.01.28 751
Board Pagination Prev 1 ... 83 84 85 86 87 88 89 90 91 92 ... 123 Next
/ 123
CLOSE