하모니 게시판

g++ 설치가 안돼는데 도와주세요~

2016.02.24 22:18

레인 조회 수:8249

안녕하세요  g++ 설치가 안돼는 사태가 발생했습니다.


아래 문제 재설치 말고 해결방법이 없을까요?


admin@hkr21 ~ $ sudo apt-get install g++
패키지 목록을 읽는 중입니다... 완료
의존성 트리를 만드는 중입니다      
상태 정보를 읽는 중입니다... 완료
몇몇 패키지를 설치할 수 없습니다. 요청한 상황이 불가능할 수도 있고,
불안정 배포판을 사용해서 일부 필요한 패키지를 아직 만들지 않았거나,
아직 Incoming에서 나오지 않은 경우일 수도 있습니다.
이 상황을 해결하는데 다음 정보가 도움이 될 수도 있습니다:

다음 패키지의 의존성이 맞지 않습니다:
 g++ : 의존: g++-4.8 (>= 4.8.2-5~) 하지만 %s 패키지를 설치하지 않을 것입니다
E: 문제를 바로잡을 수 없습니다. 망가진 고정 패키지가 있습니다.
admin@hkr21 ~ $


admin@hkr21 ~ $ sudo apt-get install libstdc++
패키지 목록을 읽는 중입니다... 완료
의존성 트리를 만드는 중입니다      
상태 정보를 읽는 중입니다... 완료
주의, 정규식 'libstdc+'에 대해 'libstdc++6-dbg-powerpc-dcv1'을(를) 선택합니다

:

<<중간 생략>>

:

주의, 'libstdc++6-dev-armel-dcv1' 대신에 'libstdc++6-4.7-dev-armel-cross' 패키지를 선택합니다

주의, 'libstdc++6-dbg-arm64-dcv1' 대신에 'libstdc++6-4.8-dbg-arm64-cross' 패키지를 선택합니다
주의, 'libstdc++6-dbg-powerpc-dcv1' 대신에 'libstdc++6-4.8-dbg-powerpc-cross' 패키지를 선택합니다
주의, 'libstdc++6-dbg-ppc64el-dcv1' 대신에 'libstdc++6-4.8-dbg-ppc64el-cross' 패키지를 선택합니다
주의, 'libstdc++6-armel-dcv1' 대신에 'libstdc++6-armel-cross' 패키지를 선택합니다
몇몇 패키지를 설치할 수 없습니다. 요청한 상황이 불가능할 수도 있고,
불안정 배포판을 사용해서 일부 필요한 패키지를 아직 만들지 않았거나,
아직 Incoming에서 나오지 않은 경우일 수도 있습니다.
이 상황을 해결하는데 다음 정보가 도움이 될 수도 있습니다:

다음 패키지의 의존성이 맞지 않습니다:
 libstdc++-4.8-dev : 의존: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04.1) 하지만 4.8.4-2ubuntu1~14.04 패키지를 설치할 것입니다
                     의존: libgcc-4.8-dev (= 4.8.4-2ubuntu1~14.04.1) 하지만 4.8.4-2ubuntu1~14.04 패키지를 설치할 것입니다
                     의존: libstdc++6 (>= 4.8.4-2ubuntu1~14.04.1) 하지만 4.8.4-2ubuntu1~14.04 패키지를 설치할 것입니다
 libstdc++-4.8-doc : 충돌: libstdc++6-4.4-doc 하지만 4.4.7-8ubuntu1 패키지를 설치할 것입니다
                     충돌: libstdc++6-4.6-doc 하지만 4.6.4-6ubuntu2 패키지를 설치할 것입니다
                     충돌: libstdc++6-4.7-doc 하지만 4.7.3-12ubuntu1 패키지를 설치할 것입니다
 libstdc++-4.8-pic : 의존: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04.1) 하지만 4.8.4-2ubuntu1~14.04 패키지를 설치할 것입니다
                     의존: libstdc++6 (>= 4.8.4-2ubuntu1~14.04.1) 하지만 4.8.4-2ubuntu1~14.04 패키지를 설치할 것입니다
 libstdc++-4.9-dev : 의존: gcc-4.9-base (= 4.9.2-0ubuntu1~14.04) 하지만 4.9.3-0ubuntu4 패키지를 설치할 것입니다
                     의존: libgcc-4.9-dev (= 4.9.2-0ubuntu1~14.04) 하지만 %s 패키지를 설치하지 않을 것입니다
                     의존: libstdc++6 (>= 4.9.2-0ubuntu1~14.04) 하지만 4.8.4-2ubuntu1~14.04 패키지를 설치할 것입니다
 libstdc++-4.9-doc : 충돌: libstdc++-4.8-doc 하지만 4.8.4-2ubuntu1~14.04.1 패키지를 설치할 것입니다
                     충돌: libstdc++6-4.4-doc 하지만 4.4.7-8ubuntu1 패키지를 설치할 것입니다
                     충돌: libstdc++6-4.6-doc 하지만 4.6.4-6ubuntu2 패키지를 설치할 것입니다
                     충돌: libstdc++6-4.7-doc 하지만 4.7.3-12ubuntu1 패키지를 설치할 것입니다
 libstdc++-4.9-pic : 의존: gcc-4.9-base (= 4.9.2-0ubuntu1~14.04) 하지만 4.9.3-0ubuntu4 패키지를 설치할 것입니다
                     의존: libstdc++6 (>= 4.9.2-0ubuntu1~14.04) 하지만 4.8.4-2ubuntu1~14.04 패키지를 설치할 것입니다
 libstdc++6-4.4-dev : 의존: g++-4.4 (= 4.4.7-8ubuntu1) 하지만 %s 패키지를 설치하지 않을 것입니다
 libstdc++6-4.6-dbg : 충돌: libstdc++6-4.4-dbg 하지만 4.4.7-8ubuntu1 패키지를 설치할 것입니다
 libstdc++6-4.6-dev : 의존: g++-4.6 (= 4.6.4-6ubuntu2) 하지만 %s 패키지를 설치하지 않을 것입니다
 libstdc++6-4.6-doc : 충돌: libstdc++6-4.4-doc 하지만 4.4.7-8ubuntu1 패키지를 설치할 것입니다
 libstdc++6-4.7-dbg : 충돌: libstdc++6-4.4-dbg 하지만 4.4.7-8ubuntu1 패키지를 설치할 것입니다
                      충돌: libstdc++6-4.6-dbg 하지만 4.6.4-6ubuntu2 패키지를 설치할 것입니다
 libstdc++6-4.7-dev : 의존: libgcc-4.7-dev (= 4.7.3-12ubuntu1) 하지만 %s 패키지를 설치하지 않을 것입니다
 libstdc++6-4.7-doc : 충돌: libstdc++6-4.4-doc 하지만 4.4.7-8ubuntu1 패키지를 설치할 것입니다
                      충돌: libstdc++6-4.6-doc 하지만 4.6.4-6ubuntu2 패키지를 설치할 것입니다
 libstdc++6-4.8-dbg : 의존: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04.1) 하지만 4.8.4-2ubuntu1~14.04 패키지를 설치할 것입니다
                      의존: libstdc++6 (>= 4.8.4-2ubuntu1~14.04.1) 하지만 4.8.4-2ubuntu1~14.04 패키지를 설치할 것입니다
                      충돌: libstdc++6-4.4-dbg 하지만 4.4.7-8ubuntu1 패키지를 설치할 것입니다
                      충돌: libstdc++6-4.6-dbg 하지만 4.6.4-6ubuntu2 패키지를 설치할 것입니다
                      충돌: libstdc++6-4.7-dbg 하지만 4.7.3-12ubuntu1 패키지를 설치할 것입니다
 libstdc++6-4.8-dbg-armhf-cross : 충돌: libstdc++6-4.7-dbg-armhf-cross 하지만 4.7.3-11ubuntu1cross1.85 패키지를 설치할 것입니다
 libstdc++6-4.9-dbg : 의존: gcc-4.9-base (= 4.9.2-0ubuntu1~14.04) 하지만 4.9.3-0ubuntu4 패키지를 설치할 것입니다
                      의존: libstdc++6 (>= 4.9.2-0ubuntu1~14.04) 하지만 4.8.4-2ubuntu1~14.04 패키지를 설치할 것입니다
                      충돌: libstdc++6-4.4-dbg 하지만 4.4.7-8ubuntu1 패키지를 설치할 것입니다
                      충돌: libstdc++6-4.6-dbg 하지만 4.6.4-6ubuntu2 패키지를 설치할 것입니다
                      충돌: libstdc++6-4.7-dbg 하지만 4.7.3-12ubuntu1 패키지를 설치할 것입니다
                      충돌: libstdc++6-4.8-dbg 하지만 4.8.4-2ubuntu1~14.04.1 패키지를 설치할 것입니다
E: 문제를 바로잡을 수 없습니다. 망가진 고정 패키지가 있습니다.
admin@hkr21 ~ $


번호 제목 추천 수 글쓴이 날짜 조회 수
공지 하모니카 5.0 Hanla 64bit 릴리즈 노트 [9] 0 JamesBae 2021.10.12 14145
공지 [공지] '하모니 소식' 게시판 변경 공지 [1] 0 LukeHan 2018.12.17 28049
462 플랭크 독(plank dock)에서 설정 아이콘이 사라진 문제를 임시로 해결. [13] file 0 세까랑 2016.03.30 8357
461 듀얼모니터 사용시 문제 [6] file 0 ryu 2016.03.29 8060
460 [제안] 많은분들이 찾아올수있도록 검색어 등록을 해주셨으면 합니다. [4] 0 Sound:D 2016.03.29 5685
459 이런 News도 올라왔네요! [6] 0 식혜고양이 2016.03.24 6097
458 티맥스소프트에서 티맥스 OS 나온다고 하는데 [11] 0 풀잎 2016.03.22 6722
457 우분투, 공식UI '유니티' 위치변경 지원 [2] 0 행복한펭귄 2016.03.22 6049
456 [질문] 리눅스 민트 화면 뜬 후 진행불능 [3] 0 나무아래서 2016.03.20 6085
455 안쓰는 노트북의 활용 팁 공유 부탁드립니다. [2] 0 나무아래서 2016.03.20 7876
454 xps 15 4k모델 dpi설정 질문 [8] 0 hom붕어 2016.03.19 8008
453 vm 리눅스 설치 관련 질문드립니다. [7] 0 onting 2016.03.19 5890
452 한국형이 뭐길래? [5] 0 행복한펭귄 2016.03.18 5946
451 한국형 ○○○ 추진했다가 실패한 정책들 [2] 0 행복한펭귄 2016.03.18 6301
450 삼성컴에 하모니를 깔았어요 [5] 0 수지 2016.03.17 6747
449 macbook에 hamonikr를 설치하면 어떨까요?? [9] 0 식혜고양이 2016.03.17 5993
448 클라우드 서비스 완전정복 [1] file 0 행복한펭귄 2016.03.16 5814
447 [질문]초보.. 플랭크 독을 어떻게 깔면되는지요? [9] 0 나무아래서 2016.03.16 7023
446 질문 드립니다; [3] 0 식혜고양이 2016.03.15 5545
445 [질문]감사합니다...부팅순서 변경..질문드려봅니다. [2] 0 나무아래서 2016.03.15 5410
444 문의드립니다 [2] 0 prussianblue 2016.03.14 5476
443 [solved] rosa에서 build-essential 설치 [1] 0 ryu 2016.03.14 6602
  • 하모니카 미디어 에디션
  • 설치가 필요없는 화상통화 하모니
loginbox2
아직 회원이 아니세요? 회원가입